I am getting a message: "You have blocked third-party cookies in your browser". What does it mean?

Q: Hello! I got the following message when using Safari:

You have blocked third-party cookies in your browser. Authorization requires third-party cookies at least for social.uploadcare.com domain.

Is this something that can be solved by using custom OAuth?

A: Custom OAuth can be used when you want your users to give permissions to your app, not Uploadcare’s to reduce surprises or hide the fact that you’re using Uploadcare.

All uploads from social networks and cloud storage services are still going through our servers. And as we need cookies to tell authenticated users from unauthenticated, custom OAuth does not affect the requirement.

I am getting the same message in Safari iPhone and have not been able to solve. Third party cookies are not blocked.

On Chrome iPhone there are no problems.

Hi @jens :wave:

To enable 3rd-party cookies in Safari (iPhone/iPad iOS 11)

  1. Open your Settings.
  2. Scroll down and select Safari.
  3. Under Privacy & Security, turn off Prevent Cross-Site Tracking and Block All Cookies.

Check out this article to learn how to do so in other browsers

Let me know if this helps.

These are my settings, but I’m still getting the error.

For reference seeing this error when using the Moskit app.

@jens thanks for the update. Can you clear browser cache/cookies for this website by clicking Clear History and Website Data and then try to connect to Google Drive once again?